The one place to get plugged into the BuzZz, from zany stories to zippy memes and everything in between.

30 Sep, Friday
° C
Image Alt

BuzZzing

This is why you should update your Apple devices right now

Apple disclosed serious security vulnerabilities for iPhones, iPads and Macs that could potentially allow attackers to take complete control of these devices.Apple released two security reports about the issue last week, although they didn’t receive wide attention outside of tech publications. Apple’s explanation of the vulnerability means a hacker could get “full admin access” to the device. That would allow intruders to impersonate the device’s owner and subsequently run any software in their name, said Rachel Tobac, CEO of SocialProof Security.

Security experts have advised users to update affected devices — the iPhone6S and later models; several models of the iPad, including the 5th generation and later, all iPad Pro models and the iPad Air 2; and Mac computers running MacOS Monterey. The flaw also affects some iPod models. Apple did not say in the reports how, where or by whom the vulnerabilities were discovered. In all cases, it cited an anonymous researcher.
Post a Comment

You don't have permission to register